How Can We Help?

Technical requirements – myGP Buddy

You are here:

This article describes the technical requirements for the myGP Buddy desktop app.

Windows administrator rights

Windows Administrator rights are not explicitly required to install the myGP Buddy client. A regular user should be able to install on their own.

If all installation of applications are blocked for non-administrator users, local IT Support team will be required to provide assistance during installation or will need to whitelist the myGP Buddy application

Installation and folder read/write access

myGP Buddy uses the OneClick install solution from Microsoft. If you require an enterprise level installation solution, please contact myGP Support to discuss this.

Read/write access is required to these folders:

C:\Users\Username\

C:\Users\Username\AppData\Local\Apps\2.0

C:\Users\Username\AppData\Local\

Where access to the above folders are blocked, myGP Buddy may be able to install, but would not be permitted to function.

Anti-virus

myGP Buddy could get blocked by anti-virus software. We advise that myGP Buddy is whitelisted on any CCG/CSU managed anti-virus solutions.

We work with the major anti-virus suppliers to verify the myGP Buddy application, which should reduce anti-virus software from blocking or generating errors when myGP Buddy is run.

Firewall requirements

Port 443 (HTTPS) is open

No restrictions to the address:

https://buddyapi.iplato.net/

Whitelist access to the following IP addresses:

  • 212.237.215.25
  • 3.8.158.27

Firewall solutions should not block the myGP Buddy application.

Proxy settings

Ensure any proxy that is in use permits access to the following domains:

  • mygp.com
  • iplato.net

Minimum PC requirements

Hardware

Minimum Specification

CPU Dual core 2Ghz processor or equivalent
Hard Drive Space 1GB of free space on the C drive
Operating Systems myGP Buddy is compatible with Windows 10, 32-bit and 64-bit system type
Monitor A minimum resolution of 1024×720
Memory 1GB of usable RAM is required. However, other applications installed on the device should also be considered because these will increase the amount of memory required for the device to run smoothly.
Connectivity Reliable internet access.
Software framework Version 4.8 of the .Net Framework

Compatible clinical systems

myGP Buddy is compatible with the following clinical systems:

  • EMIS Web
  • SystmOne

Video consultations

To ensure the smooth running of the video consultation functionality, ensure that the below technical requirements have been met:

View Remote Consultation technical requirements.

Previous Technical Requirements – EMIS Web
Table of Contents